1990 Legend transmission slipping - Acura Forums - Acura Enthusiasts Forum

Go Back  Acura Forums - Acura Enthusiasts Forum > Past Vehicles > Legend
Reload this Page >

1990 Legend transmission slipping

Legend This long running platform offered buyers both a coupe and sedan with a combination of luxury and performance...

1990 Legend transmission slipping

  #1  
Old 01-27-2013, 11:02 AM
Thread Starter
Join Date: Jan 2010
Posts: 2
Default 1990 Legend transmission slipping

1990 Legend LS, Auto
180k miles

My transmission seems to slipping. When it is cold, it is providing very little torque and consequently moves very slow from a stop. once i gain some speed and it shifts into high gear it seems ok. The sluggishness off the start gets better when it warms up. At times when it is acting sluggish, it will suddenly jump forward as if a stuck/clogged valve opened up.

Is this a standard torque converter slipping problem and i need a rebuild or is their a easy/cheap remedy?

thanks
Dave
 

Last edited by cincieddie99; 01-27-2013 at 08:39 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fireflyer141
TL
0
11-13-2013 01:44 PM
motomatt17
General Tech
0
10-17-2011 12:59 PM
x6against7
Integra
0
11-13-2007 02:24 PM
chalky fingers
New Member Area
0
05-14-2007 05:12 PM
NeoDon
Legend
1
12-28-2006 01:34 AM


Thread Tools
Search this Thread
Quick Reply: 1990 Legend transmission slipping


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.