TSX Acura's compact sedan offering performance comparable to any car in the class combined with the luxurious interior...

VSA ! issue 2006 Acura TSX Automatic

  #1  
Old 01-14-2013, 07:20 PM
Thread Starter
Join Date: Jan 2013
Posts: 6
Default VSA ! issue 2006 Acura TSX Automatic

Recently my VSA light and the "!" turned on as well, its not letting my cruise control to work. My question is how can i check if one of my speed sensors are bad? I recently took them out, cleaned them, put them back on, now when i start the car, it takes a few seconds to turn the VSA light on the cluster. Before i cleaned them it was on as soon as i started the car. The problem is a pain and i need to fix it!! Can someone who knows what to do help me?

ALSO: had a code run up U0122 Fcan/vsa

THANKS!!
 

Last edited by oleglyashenko; 01-14-2013 at 07:33 PM.
  #2  
Old 01-20-2013, 12:58 PM
WheelBrokerAng's Avatar
Administrator :
Join Date: Oct 2004
Location: Canton/Massillon Ohio 44646
Posts: 29,276
Default

Let's see if someone chimes in on that subject..|I'm also going to research it my self thru my Awesome Friend Mr. Google
 
  #3  
Old 12-14-2013, 12:32 PM
Thread Starter
Join Date: Jan 2013
Posts: 6
Default solution

Fixed the problem myself

"
My 2006 had a similar problem, no mechanic could figure out what was wrong with it. So i ended up finding out that my solenoid sensor was bad. Replaced it and BAM lights turned off, Such a relief.

Part number 37250-PRB-A01
located on top of the solenoid. The sensor could be green, blue, or gray.

You can identify it easily by looking at the part number. "

sensor can cost around $40-$60 new on ebay
 

Last edited by oleglyashenko; 02-04-2014 at 10:09 AM.
  #4  
Old 02-03-2014, 02:38 AM
Join Date: Jan 2014
Posts: 8
Default

You might wanna check the BCM as well. I guess there might be some problem in it.
 
  #5  
Old 02-03-2014, 10:25 PM
Newest Of Newbies
Join Date: Jan 2014
Location: florida
Posts: 10
Default

the same solenoid sensor trouble has been with me as well in past and i was juggled much with it then did a fix on it .. good to get that you got that too .. but what to check if to find the quality sensor as there are many in the market but how to differentiate among them
 
  #6  
Old 02-04-2014, 10:14 AM
Thread Starter
Join Date: Jan 2013
Posts: 6
Thumbs up

I purchased mine off ebay ex: http://www.ebay.com/itm/Genuine-OEM-...#ht_396wt_1124

They all seem to look the same, I just go for the "genuine" parts
 
  #7  
Old 02-11-2014, 10:51 PM
Newest Of Newbies
Join Date: Jan 2014
Location: New York City
Posts: 10
Default

this too is a tough task in today's world as there are many so similar looking designs of products are coming that makes it hard to recognize what is real or fake
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sergeyz2002
RL
1
05-26-2012 06:41 AM
miowen1
General Tech
6
06-12-2011 05:09 PM
WavyGravy20
TL
1
10-09-2010 11:13 PM
Alex5357
Private For Sale/Trade Classifieds
2
01-15-2010 02:07 AM
bloke279
TSX
0
09-07-2006 02:43 AM


Thread Tools
Search this Thread
Quick Reply: VSA ! issue 2006 Acura TSX Automatic


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.