RL Acura's 300HP All Wheel Drive luxury sedan...

1997 Acura 3.5 RL Premium w/Navigation

  #1  
Old 05-12-2009, 10:54 AM
Junior Member
Thread Starter
Join Date: May 2009
Posts: 2
Default 1997 Acura 3.5 RL Premium w/Navigation

I have a 1997 Acura 3.5 RL Premium w/Navigation. Last October I had some transmission work done on the car. Before the work was done, my navigation was working flawlessly. When I got back in the car, the little icon at the top left was not showing the satellite. I called the dealership and they said that all I had to do was unhook the battery to reset the system. Maybe I didn't unhook the battery long enough. The navigation still works, but its not follwing any roads right now. Does anyone have a suggestion on how to remedy this problem?

Thank you,
Howell
 
Attached Thumbnails 1997 Acura 3.5 RL Premium w/Navigation-img00205.jpg   1997 Acura 3.5 RL Premium w/Navigation-img00206.jpg   1997 Acura 3.5 RL Premium w/Navigation-img00207.jpg  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
acmm
RDX
3
06-12-2013 02:00 AM
Vanessa
Private For Sale/Trade Classifieds
11
01-23-2012 05:26 PM
hruehl
RL
1
05-12-2009 12:00 PM
rntichauer
New Member Area
2
05-14-2008 03:40 AM
98black cl
Private For Sale/Trade Classifieds
1
04-11-2008 12:01 AM


Thread Tools
Search this Thread
Quick Reply: 1997 Acura 3.5 RL Premium w/Navigation


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.