General Tech Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

Ignition Lock/switch issue

  #1  
Old 07-06-2012, 12:01 AM
Thread Starter
Join Date: Jun 2012
Posts: 2
Default Ignition Lock/switch issue

Hey there. Im having a strange problem with my ignition assembly. Not entirely sure if its in the lock cylinder or the switch.

When I turn the key it starts just fine. As soon as I let go of the key and it springs back to the "on" position, the car turns off. If I hold the key at just the right spot, not on enough for the starter to stay engaged or off enough, itll continue to run no problems.

This is my first Acura and I am unfamiliar with their ignition systems.

If anyone has any advice to whether its the lock cylinder or the switch I would greatly appreciate it.

Thanks for your time.

(1991 Legend)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ndrewoods
Off Topic
1
07-18-2011 09:57 PM
aldoe
General Tech
3
04-03-2009 08:57 AM
IndyDave
Interior
0
09-28-2008 08:48 PM
mbri
Integra
0
11-05-2007 01:05 PM
happgd
RSX
1
01-12-2006 10:42 AM


Thread Tools
Search this Thread
Quick Reply: Ignition Lock/switch issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.